HowToForums.net Forum Index HowToForums.net
An Open Source of Knowledge
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

HowTo Install Request-Tracker 3.4 on Ubuntu Breezy 5.10
Goto page 1, 2  Next
 
Post new topic   Reply to topic    HowToForums.net Forum Index -> Servers & Applications
View previous topic :: View next topic  
Author Message
jacob
Site Admin
Site Admin


Joined: 16 Mar 2006
Posts: 73
Location: USA

PostPosted: Thu May 11, 2006 12:28 pm    Post subject: HowTo Install Request-Tracker 3.4 on Ubuntu Breezy 5.10 Reply with quote

HowTo Install Request-Tracker 3.4 on Ubuntu Breezy 5.10

"RT is an enterprise-grade ticketing system which enables a group of people to intelligently and efficiently manage tasks, issues, and requests submitted by a community of users."
-- http://bestpractical.com/rt/

This HowTo will explain how to install request-tracker on a clean Ubuntu Server install.
It is tested on Ubuntu Breezy 5.10 and mite work with slight modifications on other versions or Debian based distros.
I create a root user as apposed to using sudo, just because i am used to it but you may add sudo in front of the commands if you prefer the sudo security default method of Ubuntu.

To activate the root user:
Code:

sudo passwd root


Enable universe in your Sources.list
Code:

cp -vpr /etc/apt/sources.list /etc/apt/sources.list.orig
vim /etc/apt/sources.list
#comment this:
###deb cdrom:...
apt-get update
apt-get install postgresql libcgi-fast-perl apache2-mpm-prefork libapache2-mod-fcgid lynx apache2-doc libapache2-mod-perl2
apt-get install request-tracker3.4



# BKUP the RT config file...I like to do this for every conf file I modify
Code:

cp -vpr /etc/request-tracker3.4/RT_SiteConfig.pm /etc/request-tracker3.4/RT_SiteConfig.pm.orig


Code:

vim /etc/request-tracker3.4/RT_SiteConfig.pm


Customize and add this...
Code:

Set($DatabaseHost   , 'localhost');
Set($DatabaseRTHost , 'localhost');


Create the user for the RT database
Code:

su postgres
psql -d template1
CREATE USER rtuser WITH PASSWORD 'wibble' CREATEDB NOCREATEUSER;
\q
exit



Customize Postgresql permissions
Code:

vim /etc/postgresql/7.4/main/pg_hba.conf
at the bottom of the file along with the other similar lines - but
above existing entries.
###according to install.debian for request-tracker
host    template1   rtuser    127.0.0.1    255.255.255.255   password
local   template1   rtuser                                   password
host    rtdb        rtuser    127.0.0.1    255.255.255.255   password
local   rtdb        rtuser                                   password

Code:

vim /etc/postgresql/7.4/main/postgresql.conf
make sure this is enabled
tcpip_socket = true


Restart Database
Code:

/etc/init.d/postgresql-7.4 restart



Test db connection
Code:

psql -d template1 -U rtuser -W
#enter password at the prompt, we set it to wibble in the example above


Create the RT DataBase
Code:

/usr/sbin/rt-setup-database-3.4 --action init --dba rtuser --prompt-for-dba-password



Configure Apache2
Code:

vim /etc/apache2/sites-available/default

Add the following line to the VirtualHost section of Apache from which you wish to serve RT
Code:

    Include "/etc/request-tracker3.4/apache2-modperl2.conf"

Code:

cd /etc/request-tracker3.4/
ln -s apache-modperl.conf apache2-modperl2.conf

vim /etc/request-tracker3.4/apache2-modperl2.conf
comment this
#PerlFreshRestart Off


Fix for the error complaining about can't find stuff
Code:

ln -s /usr/lib/perl5/Bundle/Apache2.pm /usr/lib/perl5/Apache2.pm
ln -s /usr/lib/perl5/Apache2/compat.pm /usr/lib/perl5/Apache/compat.pm
ln -s /usr/lib/perl5/Apache2/RequestUtil.pm /usr/lib/perl5/Apache/RequestUtil.pm


Restart Apache
Code:

/etc/init.d/apache2 force-reload



### You can now login to http://yourdomain.com/rt
using user root and password "password" (without quotation marks of course)
change this passwd asap via the Configuration menu


######## Mail Settings ########
This part is really network specific, but if you are going to use Request-Tracker as "support" mailbox organizer so to speak, than you need to set up the system to pull email.
One method would be using fetchmail which can grab mail from an IMAP/POP3 account and put it in the system.
The links below describe this process:
http://wiki.bestpractical.com/index.cgi?POP3Mailgate
http://wiki.bestpractical.com/index.cgi?ManualInstallation (Search for "Setting Up the Mail Gateway") for the basic email settings

These are the packages if your going for the configuration with fetchmail and postfix as the outgoing smtp server
Code:

apt-get install fetchmail fetchmailconf  fetchmail-ssl postfix ca-certificates


##DON'T Forget:
you need to have "CreateTicket" permissions on "Queue General" or any queue that you throw the emails in from the user fetching the mail


(For Search Engines)
This HowTo is aka:
HowTo install Request-Tracker on Ubuntu Breezy 5.10
HowTo install Request-Tracker on Ubuntu
Request-Tracker on Ubuntu


Enjoy!
_________________
JB
--
"You only see what your eyes want you to see"


Last edited by jacob on Mon Jun 26, 2006 12:58 pm; edited 3 times in total
Back to top
jacob
Site Admin
Site Admin


Joined: 16 Mar 2006
Posts: 73
Location: USA

PostPosted: Thu May 11, 2006 9:12 pm    Post subject: HowTo Request-Tracker Email Routing using Scrips Reply with quote

If your going to route different emails to different queues based on domains then you might just find this "Scrip" useful.
Scrip - is a terminology used in Request-Tracker to basically create an automatic rule based on a condition.

1. Make sure the system group "Everyone" has the following permissions on the General Queue:
* CreateTicket
* Comment on Ticket
* Reply on Ticket
2. Create a Scrip on the "General" queue using the parameters below.

#######################################
Description: Scrip Description
Condition: On Create
Action: User Defined
Template: Global Template Blank
Stage: TransactionCreate
Custom action preparation code: 1;

Custom action cleanup code:
Code:

# Domains we want to move
my $domains = {};

my %domain_map = (
                   '\@gmail\.com'         => "Queue 1",
                   '\@yahoo\.com'        => "Queue 2",
                   '\@hotmail\.com'      => "Queue 3",
                );

#Check each of our defined domains for a match
foreach my $domainKey (keys %domain_map ){
if($self->TicketObj->RequestorAddresses =~ /^.*?${domainKey}/) {
    # Domain matches - move to the right queue
    $self->TicketObj->SetQueue($domain_map{$domainKey});
    }
}

#######################################

And of course modify this part to suite your own needs:
Code:

                   '\@gmail\.com'         => "Queue 1",



Enjoy !
_________________
JB
--
"You only see what your eyes want you to see"
Back to top
Teresa
Guest





PostPosted: Wed May 24, 2006 4:18 pm    Post subject: Problem Installing Request-Tracker 3.4 on Ubuntu Breezy 5 Reply with quote

Hi, I am trying to configure Apache2 but I obtain the following error:

>sudo ./apache2 force-reload
* Forcing reload of web server (Apache2)... [Wed May 24 18:12:07 2006] [warn] module perl_module is already loaded, skipping

Can you help me?
Thanks a lot!
Cheers
Back to top
jacob
Site Admin
Site Admin


Joined: 16 Mar 2006
Posts: 73
Location: USA

PostPosted: Wed May 24, 2006 6:10 pm    Post subject: Re: Problem Installing Request-Tracker 3.4 on Ubuntu Breezy Reply with quote

Teresa wrote:

>sudo ./apache2 force-reload
* Forcing reload of web server (Apache2)... [Wed May 24 18:12:07 2006] [warn] module perl_module is already loaded, skipping



Try to review the following steps...

jacob wrote:


Configure Apache2
Code:

vim /etc/apache2/sites-available/default

Add the following line to the VirtualHost section of Apache from which you wish to serve RT
Code:

    Include "/etc/request-tracker3.4/apache2-modperl2.conf"

Code:

cd /etc/request-tracker3.4/
ln -s apache-modperl.conf apache2-modperl2.conf

vim /etc/request-tracker3.4/apache2-modperl2.conf
comment this
#PerlFreshRestart Off


Fix for the error complaining about can't find stuff
Code:

ln -s /usr/lib/perl5/Bundle/Apache2.pm /usr/lib/perl5/Apache2.pm
ln -s /usr/lib/perl5/Apache2/compat.pm /usr/lib/perl5/Apache/compat.pm
ln -s /usr/lib/perl5/Apache2/RequestUtil.pm /usr/lib/perl5/Apache/RequestUtil.pm


Restart Apache
Code:

/etc/init.d/apache2 force-reload



_________________
JB
--
"You only see what your eyes want you to see"
Back to top
zer0hmz



Joined: 28 Jun 2006
Posts: 1

PostPosted: Wed Jun 28, 2006 4:15 pm    Post subject: Reply with quote

Jacob,
I wanted to take a moment to say 'Thank you'. Thank you for putting out such a simple and easy to follow tutorial on how to install RT. I have spent A LOT of time trying to get it to work following the wiki on their board which points to FastCGI, I changed a couple of things to run what you suggested ( libapache2-mod-perl2 ) and it worked right away (at least the page is loading).

Again, thanks again for taking the time to put this up. Its gonna help a lot of people out there! You may even want to send it to Best Practical so they can update their Wiki.

Thanks man.
Back to top
julseb



Joined: 24 Aug 2006
Posts: 3

PostPosted: Thu Aug 24, 2006 4:15 pm    Post subject: Reply with quote

nice HOW to idd but i did all things as u said except im using mysql but i created db, and did all other things u said but i got this error again:


Code:

You're almost there!
You haven't yet configured your webserver to run RT. You appear to have installed RT's web interface correctly, but haven't yet configured your web server to "run" the RT server which powers the web interface. The next step is to edit your webserver's configuration file to instruct it to use RT's mod_perl, fastcgi or speedycgi handler. If you need commercial support, please contact us at sales@bestpractical.com.


resume what i did:

installed all package except postgresl, create db sucessfully, create all symbolic link, added line in /etc/apache2/sites-available/default, but allways this message..

HAve someone got one idea?
Back to top
jacob
Site Admin
Site Admin


Joined: 16 Mar 2006
Posts: 73
Location: USA

PostPosted: Thu Aug 24, 2006 5:51 pm    Post subject: Reply with quote

julseb wrote:
nice HOW to idd but i did all things as u said except im using mysql but i created db, and did all other ......


Can you please compare your apache config with the ones posted here:
http://howtoforums.net/viewtopic.php?t=48

If that didn't help than i would need to see your:
/etc/apache2/sites-available/default
...to further assist.

JB
Back to top
julseb



Joined: 24 Aug 2006
Posts: 3

PostPosted: Thu Aug 24, 2006 10:48 pm    Post subject: Reply with quote

Code:
NameVirtualHost *:80
<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
                # This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                # Commented out for Ubuntu
                #RedirectMatch ^/$ /apache2-default/
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

#Redirect Request-Tracker to SSL
#RewriteEngine   on
#RewriteCond     %{SERVER_PORT} ^80$
#RewriteRule     ^/rt(.*)$ https://%{SERVER_NAME}/rt$1 [L,R]
#RewriteLog      "/var/log/apache2/rewrite.log"
#RewriteLogLevel 2

#Request-Tracker Uncomment below if you are not redirecting and you  to answer on port 80
Include "/etc/request-tracker3.4/apache2-modperl2.conf"

</VirtualHost>


its mine defaut file cuz i want use port 80 for RT

thx in advance Jacob
Back to top
jacob
Site Admin
Site Admin


Joined: 16 Mar 2006
Posts: 73
Location: USA

PostPosted: Sat Aug 26, 2006 4:21 am    Post subject: Reply with quote

Well...
At this point, I would recommend trying to rule out the basics...
Is your server listening on port 80?
Code:

netstat -tap |grep LIST

What page do you get if you browse to your servers IP or even to:
http://localhost
or
http://localhost/rt
Did you look at the apache logs?
Try to tail them all while you access the page?
The more info i have the faster I will be able to assist you and get you going.

JB
Back to top
julseb



Joined: 24 Aug 2006
Posts: 3

PostPosted: Thu Aug 31, 2006 2:49 pm    Post subject: Reply with quote

i did this install on Debian with apache2 and work successfully. Dunno why not work correctly on breezy cuz i have any error in log.

i'll search later why bugged on breezy, i'll try at first on Debian.
Back to top
Acki



Joined: 12 Sep 2006
Posts: 3

PostPosted: Tue Sep 12, 2006 3:37 am    Post subject: Same senirio but different problem Reply with quote

Hi Jacob,

I have followed all the instaruction mentioned above discussion on debian but apache server stops starting.

when i do /etc/init.d/apache2 restart it savs to me

Forcing reload of web server: Apache2grep: /etc/apache2/mods-enabled/rewrite.load: Too many levels of symbolic links
... failed!
You may still have some apache2 processes running. There are
processes named 'apache2' which do not match your pid file,
and in the name of safety, we've left them alone. Please review
the situation by hand.
apache2: could not open document config file /etc/apache2/mods-enabled/rewrite.load



or same thing on /etc/init.d/apache2 force-reload


when i checked netstat -tap |grep LIST

it says following

dimond:~# netstat -tap |grep LIST
tcp 0 0 *:whois *:* LISTEN 1928/inetd
tcp 0 0 *:www *:* LISTEN 2127/apache
tcp 0 0 *:postgresql *:* LISTEN 2099/postmaster
tcp 0 0 *:smtp *:* LISTEN 2021/master
tcp6 0 0 *:ssh *:* LISTEN 2114/sshd
tcp6 0 0 *:postgresql *:* LISTEN 2099/postmaster
tcp6 0 0 *:smtp *:* LISTEN 2021/master


http://localhost is showing default page

http://localhost/rt is showing

The page cannot be found
The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

i checked logs but both of the following files are empty
tail /var/log/apache2/access.log
tail /var/log/apache2/error.log

Please Suggest me in this regard

Thanks in advance
Acki
Back to top
jacob
Site Admin
Site Admin


Joined: 16 Mar 2006
Posts: 73
Location: USA

PostPosted: Tue Sep 12, 2006 12:12 pm    Post subject: Reply with quote

Hi Acki,
It seems from your description, that you have some other program using apache2...

Is this a fresh Debian install?
What version of Debian is it?

Hack 1:
Code:

cd /etc/apache2/mods-enabled/
ln -s ../mods-available/rewrite.load .


You mite also want to check the newer 6.06 HowTo to see if you missed any steps:
http://howtoforums.net/viewtopic.php?t=48

if Apache is complaining that it is started than try killing it manually then starting it:
Code:

tail -f /var/log/apache2/access.log /var/log/apache2/error.log &
ps aux |grep -i apache
killall -9 <proccess ID>
/etc/init.d/apache2 start


If all this still doesn't help, then paste you conf files and we will go from there.

JB
Back to top
Acki



Joined: 12 Sep 2006
Posts: 3

PostPosted: Tue Sep 12, 2006 5:00 pm    Post subject: Reply with quote

Hi Jacob
Thanks for your reply, Here are the answers of the queries u asked.

>Is this a fresh Debian install?
yes this is a fresh install

>What version of Debian is it?
2.6.8-2-386 is the version of this install.

>tail -f /var/log/apache2/access.log /var/log/apache2/error.log

Both of these files are still empty.


dimond:~# ps aux |grep -i apache
root 2124 0.0 0.8 6940 4356 ? S 08:55 0:00 /usr/sbin/apache
www-data 2127 0.0 0.8 6940 4352 ? S 08:55 0:00 /usr/sbin/apache
www-data 2128 0.0 0.8 6940 4352 ? S 08:55 0:00 /usr/sbin/apache
www-data 2129 0.0 0.8 6940 4352 ? S 08:55 0:00 /usr/sbin/apache
www-data 2130 0.0 0.8 6940 4352 ? S 08:55 0:00 /usr/sbin/apache
www-data 2131 0.0 0.8 6940 4352 ? S 08:55 0:00 /usr/sbin/apache

dimond:~# killall -9 2124
2124: no process killed
dimond:~# killall -9 2127
2127: no process killed
dimond:~# killall -9 2128
2128: no process killed
dimond:~# killall -9 2129
2129: no process killed
dimond:~# killall -9 2130
2130: no process killed

> /etc/init.d/apache2 start

Starting web server: Apache2Syntax error on line 16 of /etc/request-tracker3.4/apache2-modperl2.conf:
Invalid command 'PerlModule', perhaps mis-spelled or defined by a module not included in the server configuration


>If all this still doesn't help, then paste you conf files and we will go from there

NameVirtualHost *:80
<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
# This directive allows us to have apache2's default start page
# in /apache2-default/, but still have / go to the right place
#RedirectMatch ^/$ /apache2-default/
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

#Redirect Request-Tracker to SSL
# RewriteEngine on
# RewriteCond %{SERVER_PORT} ^80$
# RewriteRule ^/rt(.*)$ https://%{SERVER_NAME}/rt$1 [L,R]
# RewriteLog "/var/log/apache2/rewrite.log"
# RewriteLogLevel 2

#Request-Tracker Uncomment below if you are not redirecting and you want to answer on port 80
Include "/etc/request-tracker3.4/apache2-modperl2.conf"

</VirtualHost>

Regards
Acki
Back to top
Acki



Joined: 12 Sep 2006
Posts: 3

PostPosted: Wed Sep 13, 2006 1:57 am    Post subject: Reply with quote

Hi Jacob,

I have installed another server. I try to troubleshoot but still a error is there, i know i am missing any configuration action.

Well I am sending you details of this server and the error I am facing.

>Version of Debian.
2.6.8-2-386 is the version of this install.

>tail -f /var/log/apache2/access.log

Starting web server: Apache2Syntax error on line 26 of /etc/request-tracker3.4/apache2-modperl2.conf:
Invalid command 'RewriteEngine', perhaps mis-spelled or defined by a module not included in the server configuration
beta:/usr/lib/perl5/Apache# tail /var/log/apache2/access.log
203.92.35.12 - - [13/Sep/2006:04:27:40 +0530] "GET / HTTP/1.1" 302 340 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)"
203.92.35.12 - - [13/Sep/2006:04:27:40 +0530] "GET /apache2-default/ HTTP/1.1" 200 1457 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)"
203.92.35.12 - - [13/Sep/2006:04:27:40 +0530] "GET /apache2-default/apache_pb.gif HTTP/1.1" 200 2326 "http://192.168.1.222/apache2-default/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)"
203.92.35.12 - - [13/Sep/2006:04:27:40 +0530] "GET /favicon.ico HTTP/1.1" 404 328 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)"

>/var/log/apache2/error.log

[Wed Sep 13 04:55:34 2006] [notice] Apache/2.0.54 (Debian GNU/Linux) mod_perl/1.999.21 Perl/v5.8.4 configured -- resuming normal operations
[Wed Sep 13 04:55:38 2006] [notice] caught SIGTERM, shutting down
[Wed Sep 13 05:05:11 2006] [notice] Apache/2.0.54 (Debian GNU/Linux) mod_perl/1.999.21 Perl/v5.8.4 configured -- resuming normal operations
[Wed Sep 13 05:05:14 2006] [notice] caught SIGTERM, shutting down
[Wed Sep 13 05:05:17 2006] [notice] Apache/2.0.54 (Debian GNU/Linux) mod_perl/1.999.21 Perl/v5.8.4 configured -- resuming normal operations
[Wed Sep 13 05:05:44 2006] [notice] caught SIGTERM, shutting down
[Wed Sep 13 05:06:39 2006] [notice] Apache/2.0.54 (Debian GNU/Linux) mod_perl/1.999.21 Perl/v5.8.4 configured -- resuming normal operations
[Wed Sep 13 05:06:52 2006] [notice] caught SIGTERM, shutting down
[Wed Sep 13 05:09:59 2006] [notice] Apache/2.0.54 (Debian GNU/Linux) mod_perl/1.999.21 Perl/v5.8.4 configured -- resuming normal operations
[Wed Sep 13 05:10:01 2006] [notice] caught SIGTERM, shutting down

>ps aux |grep -i apache

root 2308 0.0 0.1 2708 492 pts/0 R+ 05:18 0:00 grep -i apache

> killall -9 2308

2308: no process killed

>/etc/init.d/apache2 start

Starting web server: Apache2Syntax error on line 26 of /etc/request-tracker3.4/apache2-modperl2.conf:
Invalid command 'RewriteEngine', perhaps mis-spelled or defined by a module not included in the server configuration

>/etc/init.d/apache2 force-reload

You may still have some apache2 processes running. There are processes named 'apache2' which do not match your pid file,and in the name of safety, we've left them alone. Please review
the situation by hand.
Syntax error on line 26 of /etc/request-tracker3.4/apache2-modperl2.conf: Invalid command 'RewriteEngine', perhaps mis-spelled or defined by a module not included in the server configuration

>vi /etc/apache2/sites-available/default file

NameVirtualHost *
<VirtualHost *>
ServerAdmin webmaster@localhost
DocumentRoot /var/www/
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
# This directive allows us to have apache2's default start page
# in /apache2-default/, but still have / go to the right place
RedirectMatch ^/$ /apache2-default/
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog /var/log/apache2/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog /var/log/apache2/access.log combined
ServerSignature On

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

#Request-Tracker Uncomment below if you are not redirecting and you to answer on port 80
Include "/etc/request-tracker3.4/apache2-modperl2.conf"

</VirtualHost>

Suggest me,

Thanks n Regards
Acki
Back to top
jacob
Site Admin
Site Admin


Joined: 16 Mar 2006
Posts: 73
Location: USA

PostPosted: Wed Sep 13, 2006 2:09 pm    Post subject: Reply with quote

Well..

Taking in consideration that this howto is certified with Ubuntu, and you are installing a fresh server anyhow...

what I can recommend you to do is try out the latest Ubuntu 6.06 + Request Tracker fresh install according to this guide:
http://howtoforums.net/viewtopic.php?t=48

Download Ubuntu here:
http://www.ubuntu.com/download

Then if things go well, we can compare and try to write a HowTo for Debian.

JB
Back to top
Display posts from previous:   
Post new topic   Reply to topic    HowToForums.net Forum Index -> Servers & Applications All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group